Long Jump Stats - eXtreme Modification

Started by NumB
31/07/2007 04:55
Page 4 of 24
NumB20/08/2007 17:37

Ah... I foth its impossible, but now i see it is (perfect bhop-bug). Yes its fixable. Fixed it in 5minutes, althow I don't wanna botter fAker with my updates to much... =P

trb21/08/2007 07:41

:) nice

jeflefou21/08/2007 17:28

In the function named "pfn_touch", the variable ClassName2 is not initialized...

I think it should be made in the second "if" condition, do you understand me?

dEMolite mapper21/08/2007 18:45

Requesting a Usercommand which turns the announcement from the stats off for the induvialusers.

NumB21/08/2007 22:07


In the function named "pfn_touch", the variable ClassName2 is not initialized...

I think it should be made in the second "if" condition, do you understand me?

jeflefou

Yah, I got it. Fixed. Althow i'll release update lather.


Requesting a Usercommand which turns the announcement from the stats off for the induvialusers.

dEMolite

Sry, i didn't understand what you are trying to say. =P

electron21/08/2007 22:17

He means.

A command that can posted in chat, which will turn off the sounds made by the plugin for the individual users. (kz_lj_sounds "0")

NumB22/08/2007 01:05

I realy don't think, that its thet needed, cuz I don't wanna make this plugin using to much commands. + it will be to much checks when player is tuching the ground...

dEMolite mapper22/08/2007 02:36

but it is anyoning on public jumpservers where you are going to climb and after 1-4mins one connecting
typed /ljstats and then he makes only Ljs then. And thats the biggest problems on publicservers since the release of the ljstats.

dayletter22/08/2007 08:15

L 08/22/2007 - 14:14:11: [AMXX] Run time error 4: index out of bounds
L 08/22/2007 - 14:14:11: [AMXX] [0] colorchat.inc::ColorChat (line 76)
L 08/22/2007 - 14:14:11: [AMXX] [1] kz_ljs_xm.sma::fwdStartFrame (line 818)

This error keeps flooding the console since I open the server.
However, after a map change it just goes fine.




[ Edited 08/22/07 - 08:19:47 ]

remo22/08/2007 18:01

there is a protection? no more than 8 strafes?:D never saw the plugin giving out more than 8 strafes..^^

and sometimes the plugin doesnt show anything oO

NumB23/08/2007 12:13


but it is anyoning on public jumpservers where you are going to climb and after 1-4mins one connecting
typed /ljstats and then he makes only Ljs then. And thats the biggest problems on publicservers since the release of the ljstats.

dEMolite

Evry body has rights to ljump. I don't think you have to need special access 4 thet. Let hem to lj, whats the problem? Ya, sometimes there are longjump flooders, but they usaly stop after 2-3 minutes.



L 08/22/2007 - 14:14:11: [AMXX] Run time error 4: index out of bounds
L 08/22/2007 - 14:14:11: [AMXX] [0] colorchat.inc::ColorChat (line 76)
L 08/22/2007 - 14:14:11: [AMXX] [1] kz_ljs_xm.sma::fwdStartFrame (line 818)

This error keeps flooding the console since I open the server.
However, after a map change it just goes fine.

dayletter

In new version its fixed.



there is a protection? no more than 8 strafes?:D never saw the plugin giving out more than 8 strafes..^^

and sometimes the plugin doesnt show anything oO

remo

Sometimes you need to w8 4 the beam 2 disapear, or it won't write next jump stats. Strafe protection? Why on earth do you need it (there are jumpers that do more then 8 strafes, if what)?

remo23/08/2007 15:00

i asked if there is 1.. because this plugin never shows me 9 strafes..

Melk1y25/08/2007 13:00

hepl pls

[AMXX] Loaded 2 admins from file
Cmd_AddCommand: say already defined
L 08/25/2007 - 14:57:41: [AMXX] Run time error 4 (plugin "kz_ljs_xm.amxx") - debug not enabled!
L 08/25/2007 - 14:57:41: [AMXX] To enable debug mode, add "debug" after the plugin name in plugins.ini (without quotes).
:confused:

DaTa25/08/2007 22:26

L 08/25/2007 - 00:24:48: Start of error session.
L 08/25/2007 - 00:24:48: Info (map "kzfr_longjump") (logfile "error_082507.log")
L 08/25/2007 - 00:24:48: [AMXX] Displaying debug trace (plugin "kz_ljs_xm.amxx")
L 08/25/2007 - 00:24:48: [AMXX] Run time error 11: divide
L 08/25/2007 - 00:24:48: [AMXX] [0] kz_ljs_xm.sma::fwdPlayerPreThink (line 1106)
L 08/25/2007 - 00:24:48: [AMXX] [1] kz_ljs_xm.sma::fwdPlayerPostThink (line 1705)

Sorry, if old

EDITED: on v.2.10
[ Edited 08/25/07 - 22:30:28 ]

NumB26/08/2007 00:28

Ok, fixed that error log and perfect-bhop bug. Version 2.12 (if you don't see it in a first post, you can find it in the second post :P ).

Fixed: errorlog.
Fixed: beam-bug (ljstats won't work untill last beam desapears).
Fixed: perfect-bhop bug.
Changed: ColorChat include - you don't need to add anything in plugin_init now (code).

[ Edited 08/26/07 - 14:26:57 ]

DaTa26/08/2007 00:56

v.2.11:
L 08/25/2007 - 23:39:12: [AMXX] Displaying debug trace (plugin "kz_ljs_xm.amxx")
L 08/25/2007 - 23:39:12: [AMXX] Run time error 4: index out of bounds
L 08/25/2007 - 23:39:12: [AMXX] [0] colorchat.inc::ColorChat (line 76)
L 08/25/2007 - 23:39:12: [AMXX] [1] kz_ljs_xm.sma::fwdStartFrame (line 818)

v.2.10
On kz_fastrun on start there is trigger, what accelerate players. My lj10 table now is suxx, every one now is super-mega ljumper...

ps sorry for my 5yo english :down:

[ Edited 08/26/07 - 01:19:33 ]

NumB26/08/2007 01:36


v.2.11:
L 08/25/2007 - 23:39:12: [AMXX] Displaying debug trace (plugin "kz_ljs_xm.amxx")
L 08/25/2007 - 23:39:12: [AMXX] Run time error 4: index out of bounds
L 08/25/2007 - 23:39:12: [AMXX] [0] colorchat.inc::ColorChat (line 76)
L 08/25/2007 - 23:39:12: [AMXX] [1] kz_ljs_xm.sma::fwdStartFrame (line 818)

v.2.10
On kz_fastrun on start there is trigger, what accelerate players. My lj10 table now is suxx, every one now is super-mega ljumper...

ps sorry for my 5yo english :down:

DaTa

Download v2.12 (you can find it in my second post untill fAker will aprove it). :)
[ Edited 08/26/07 - 01:36:48 ]

theL0w^26/08/2007 01:59

v 2.12 - by KZRU - http://climbers.cpms.ru/view_download.php?id=408

dEMolite mapper26/08/2007 02:17

Originally posted by dEMolite
but it is anyoning on public jumpservers where you are going to climb and after 1-4mins one connecting
typed /ljstats and then he makes only Ljs then. And thats the biggest problems on publicservers since the release of the ljstats.

NumB

Evry body has rights to ljump. I don't think you have to need special access 4 thet. Let hem to lj, whats the problem? Ya, sometimes there are longjump flooders, but they usaly stop after 2-3 minutes.


But not everyone wants to see the anouncements. Thats the point. It should be allowed by users to disable the anouncements for themselfs.

kid74101026/08/2007 09:07

2.12 Good!!!

Page 4 of 24

Please log in to post replies.